人脸插件开源【梦苍】 开源

Developer MC梦苍 17天前 88

嘎嘎,时隔半年,我又回来了。

由于封禁和插件已经没有多少人使用,整理开源一批插件。


https://f.mypcqq.cc/thread-6335.htm


小冰颜值测算


.版本 2

.支持库 internet

.子程序 图片_颜值测算, 颜值, 公开

.参数 图片, 文本型

.局部变量 文本, 文本型

.局部变量 正则, 正则表达式类

.局部变量 颜值, 颜值

.局部变量 cookies, 文本型

网页_访问S (“http://kan.msxiaobing.com/V3/Portal?task=yanzhi”, , , , cookies)  ' 此步为访问页面,已获取cookie

文本 = 网页访问u (“http://kan.msxiaobing.com/Api/Image/UploadBase64”, 1, 编码_BASE64编码 (HTTP读文件 (图片)), , , , , , , )  ' 此为获取编码后的图片服务器地址


正则.创建 (#正则_颜值, 文本) #正则_颜值=\{"Host":"(.*?)","Url":"(.*?)"\}

文本 = 编码_Utf8到Ansi (网页_GZIP解压 (到字节集 (网页_访问_对象 (“https://kan.msxiaobing.com/Api/ImageAnalyze/Process?service=yanzhi&tid=38a996c6378341a29d37d678cf2973e6”, 1, “MsgId=” + 到文本 (时间_北京转格林威治 (取现行时间 ())) + “&CreateTime=” + 时间_取现行时间戳 (真) + “&Content%5BimageUrl%5D=” + 编码_URL编码 (正则.取子匹配文本 (1, 1) + 正则.取子匹配文本 (1, 2), 真, 真), cookies, , #协议头_微软小冰_侧颜协议头))))  


正则.创建 (#正则_颜值信息, 文本) #正则_颜值信息=\{"msgId":".*?","timestamp":.*?,"receiverId":.*?,"content":\{"text":"(.*?)","imageUrl":"(.*?)","metadata":\{"AnswerFeed":".*?","w":".*?","aid":".*?"\}\}\}

颜值.测算内容 = 正则.取子匹配文本 (1, 1)

颜值.测算图片 = 正则.取子匹配文本 (1, 2)

.如果 (颜值.测算内容 ≠ “” 且 颜值.测算图片 ≠ “”)

    返回 (颜值)

.否则

    颜值.测算内容 = “”

    颜值.测算图片 = “”

.如果结束

返回 (颜值)


最新回复 (0)
    • MyPCQQ官方站
      2
        登陆 注册 QQ登陆(暂不可用)
返回